Peachtree & Pervasive port 1583

Last post 01-24-2007 10:52 AM by achild@pervasive.com. 5 replies.
Page 1 of 1 (6 items)
Sort Posts: Previous Next
  • 01-23-2007 12:39 PM

    Peachtree & Pervasive port 1583

    We are trying to install Peachtree accounting that uses the Pervasive SQL 9.11 Pervasive is "listening" on port 1583 which conflicts with our backup systems. Is there a way to configure Pervasive to use a different port?
  • 01-23-2007 1:05 PM In reply to

    Re: Peachtree & Pervasive port 1583

    This will require both server and client side changes. All documented. On line you can find it athttp://www.pervasive.com/library/. On the left hand tree navigate to
    Pervasive Library
    Documentation
    Pervasive PSQL
    Pervasive PSQL v9 SP2 (9.5)
    Advanced Operations Guide
    Configuration Reference
    Server Configuration Parameters
    then find the TCP/IP Port description. It links to a description on how to set the client connection parameters too.
  • 01-23-2007 2:47 PM In reply to

    Re: Peachtree & Pervasive port 1583

    The flip side of this advice is that the TCP well known port 1583 is registered to the SQL engine that Pervasive uses.
    So for correctnes the backup system should be the one moved to another port. Only if the backup software can not be reconfigured (single client I am guessing) should all of the machines using Pervasive.SQL be reconfigured. Other factors could be that it is a non-issue if Peachtree does not use the SQL engine to impossible to change if the application uses a dsn-less connection... there would be no DSN to change the setting on...
  • 01-24-2007 10:46 AM In reply to

    Re: Peachtree & Pervasive port 1583

    Hi Anne,
    We did as you suggested and changed the ports to 1580 and 3355, but we still hare having a problem. I found this in the pvsw log file. Any thoughts?
    01-24-2007 09:25:23 MKDE 00000950 w3dbsmgr.exe LONGMORN I Resources released
    01-24-2007 09:28:20 MKDE 000008F8 w3dbsmgr.exe LONGMORN W Resources allocated
    01-24-2007 09:28:21 W3COMSRV 000008F8 w3dbsmgr.exe LONGMORN E WinSock listen() error=10013.
    01-24-2007 09:28:21 MKDE 000008F8 w3dbsmgr.exe LONGMORN I Error initializing the TCP/IP protocol. Error code: 10013.
    01-24-2007 09:28:23 SQLManager 000008F8 w3dbsmgr.exe LONGMORN I -1073741811 Listener failed.

    quote:

    This will require both server and client side changes. All documented. On line you can find it athttp://www.pervasive.com/library/. On the left hand tree navigate to
    Pervasive Library
    Documentation
    Pervasive PSQL
    Pervasive PSQL v9 SP2 (9.5)
    Advanced Operations Guide
    Configuration Reference
    Server Configuration Parameters
    then find the TCP/IP Port description. It links to a description on how to set the client connection parameters too.

  • 01-24-2007 10:50 AM In reply to

    Re: Peachtree & Pervasive port 1583

    Hi Anne,

    We did as you suggested and changed the default ports, but things still seem out of whack. I found this in the pvsw.log Any thoughts?
    01-24-2007 09:25:23 MKDE 00000950 w3dbsmgr.exe LONGMORN I Resources released
    01-24-2007 09:28:20 MKDE 000008F8 w3dbsmgr.exe LONGMORN W Resources allocated
    01-24-2007 09:28:21 W3COMSRV 000008F8 w3dbsmgr.exe LONGMORN E WinSock listen() error=10013.
    01-24-2007 09:28:21 MKDE 000008F8 w3dbsmgr.exe LONGMORN I Error initializing the TCP/IP protocol. Error code: 10013.
    01-24-2007 09:28:23 SQLManager 000008F8 w3dbsmgr.exe LONGMORN I -1073741811 Listener failed.

    Thanks,Paul
  • 01-24-2007 10:52 AM In reply to

    Re: Peachtree & Pervasive port 1583

    1) if 1583 is your only conflict, don't change 3351.
    2) Winsock error 10013 is WSAEACCESS -"Permission denied. An attempt was made ot access a socket in a way forbidden by the access permissions."

    You will likely need to allow your newly chosen ports to be exposed via your firewall.
Page 1 of 1 (6 items)