Pervasive V11 Client

Last post 02-22-2012 10:44 AM by Mirtheil. 8 replies.
Page 1 of 1 (9 items)
Sort Posts: Previous Next
  • 02-22-2012 7:57 AM

    Pervasive V11 Client

    Hi is it possible for a V11 Client to connect to a V9 server?
  • 02-22-2012 8:05 AM In reply to

    Re: Pervasive V11 Client

     It may work, but there is no guarantee.  Please see the link below for more information.

    "Client requesters that are a newer version than the database engine may or may not function correctly. Pervasive does not guarantee that newer versions of client requesters will function correctly with older versions of the engine. Therefore, Pervasive recommends that you avoid the use of newer version client requesters with an older engine."

     http://docs.pervasive.com/products/database/psqlv11/wwhelp/wwhimpl/js/html/wwhelp.htm#href=getstart/aitshoot.14.09.html

  • 02-22-2012 8:45 AM In reply to

    • Paul
    • Top 150 Contributor
    • Joined on 02-22-2008
    • Posts 44

    Re: Pervasive V11 Client

      I know it doesn't work with our application if that's any help

  • 02-22-2012 9:02 AM In reply to

    Re: Pervasive V11 Client

     If the v11 client doesn't work with your application accessing a v9 server, you should install the v9 client.  That would be the best option for what you need. 

  • 02-22-2012 9:39 AM In reply to

    Re: Pervasive V11 Client

    Thanks for your post but unfortunately the new clients are being installed on Windows 7 which from all reports V9 is not supported.
  • 02-22-2012 9:50 AM In reply to

    Re: Pervasive V11 Client

     You are correct in that Windows 7 was not a tested or supported platform for v9.  You might still be able to install the client.  Most of the problems with v9 on Windows 7 are related to the Workgroup engine and not the client. 

    Have you tried installing the v9 client on a Windows 7 machine and trying your application?  

  • 02-22-2012 10:05 AM In reply to

    • Paul
    • Top 150 Contributor
    • Joined on 02-22-2008
    • Posts 44

    Re: Pervasive V11 Client

    Again I can only speak in terms of our app but I'm running v9.7 client on my win 7 64Bit without issue.

  • 02-22-2012 10:35 AM In reply to

    Re: Pervasive V11 Client

    The program that would be using the engine is Accpac Version 5.5 was anyone able to accomplish this on Windows 7 without updating the client or the server Windows Server 2003 -> Pervasive Engine 9.6
  • 02-22-2012 10:44 AM In reply to

    Re: Pervasive V11 Client

     Have you tried it?  Did it work?  You've got two parts there.  One is the PSQL part and one is the Accpac part.  If you install the v9 client on a Windows 7 client, can you open a PSQL file on the server (running v9.6) using the Function Executor or PCC?  If that works, does Accpac work?  If not, and the error isn't a Btrieve/PSQL error, you might need to go back to Accpac to find out what your next step is.

Page 1 of 1 (9 items)